Clone Tools
  • last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
[RHDM-376 DROOLS-2305] Use Java 8 Eclipse compiler options when running on Java 9 (#1766)

* Use Java 8 Eclipse compiler options when running on Java 9

* Fix a test to expect java 1.8 source compiler options

    • -2
    • +2
    ./compilers/NativeJavaCompilerSettingsTest.java
  1. … 2 more files in changeset.
[RHDM-376 DROOLS-2305] Use Java 8 Eclipse compiler options when running on Java 9 (#1765)

* Use Java 8 Eclipse compiler options when running on Java 9

(cherry picked from commit 5842704)

* Fix a test to expect java 1.8 source compiler options

    • -2
    • +2
    ./compilers/NativeJavaCompilerSettingsTest.java
  1. … 2 more files in changeset.
[DROOLS-1220] configure NativeJavaCompiler using the provided settings (#824)

* only source+target levels are configured right now (via the

JavaDialectConfiguration). More options can be added later

if needed

    • -0
    • +59
    ./compilers/NativeJavaCompilerSettingsTest.java
  1. … 3 more files in changeset.