Clone
Marek Novotný <hotmana76@gmail.com>
committed
on 01 Sep
Upgrade Weld and java ee apis to be compatible with Wildfly 19+/EAP 7.3 (#388)
* removed dependency on IP-BOM

* BXMSPROD-685: upgrading dep… Show more
Upgrade Weld and java ee apis to be compatible with Wildfly 19+/EAP 7.3 (#388)

* removed dependency on IP-BOM

* BXMSPROD-685: upgrading deps for WF 18+

* fixed invalid xml configuration of plugins if there is combine.self

* fixed weld-core-impl dep declaration

* Reverted Jakarta bean validation changes

* reverted spec upgrades

* JEE8 annotation overrride

* cleaning comments about version properties and formatting

* fixed some odd things after merge

* reverted doc related to hibernate-validator

* reverted websocket api upgrade

* Upgrade websocket to jee8

* fixing jboss-websocket-api_1.1_spec references

* migrated forkMode config for maven-failsafe-plugin

* fixed jetty classes

* fixed Weld reported error

* forkMode replaced with forkCount and reuseForks

* added errai-javax-enterprise to jpa and jaxrs clients

* WELD-2635: upgrade to 3.1.5.SP1

* added errai-javax-enterprise to errai-validation module

* rolled back removed ApplicationScoped pages

Co-authored-by: Adriel Paredes <adriel.paredes@gmail.com> Show less