WildFly

Clone Tools
  • last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
[WFLY-12298] Implement RESTEasy context parameters in Wildfly

    • -0
    • +5
    /galleon-pack/src/main/resources/feature_groups/jaxrs.xml
    • -0
    • +319
    /jaxrs/src/main/java/org/jboss/as/jaxrs/JaxrsAttribute.java
    • -0
    • +77
    /jaxrs/src/main/java/org/jboss/as/jaxrs/JaxrsConstants.java
    • -0
    • +89
    /jaxrs/src/main/java/org/jboss/as/jaxrs/JaxrsElement.java
    • -0
    • +130
    /jaxrs/src/main/java/org/jboss/as/jaxrs/JaxrsParamHandler.java
    • -0
    • +179
    /jaxrs/src/main/java/org/jboss/as/jaxrs/JaxrsServerConfig.java
  1. … 22 more files in changeset.
[WFLY-12609] Mark new modules as private API, the public API is the official MicroProfile JWT API.

[WFLY-12940]:Upgrade JBossWS to 5.4.0.Final

Merge pull request #12900 from chengfang/WFLY-12958-async-tx

WFLY-12958 Calling Asynchronous EJB will use the propagated caller tr…

[WFLY-12985] Move openapi from the ee feature pack and dists to the full one

As with Fault Tolerance this means removal of this feature from the legacy non-Galleon feature pack.

    • -0
    • +16
    /ee-build/src/verifier/verifications.xml
    • -0
    • +16
    /ee-dist/src/verifier/verifications.xml
    • -2
    • +0
    /ee-galleon-pack/wildfly-feature-pack-build.xml
  1. … 20 more files in changeset.
[WFLY-12985] Move fault-tolerance from the ee feature pack and dists to the full one

This removes fault-tolerance from the 'legacy' non-Galleon feature packs. Legacy f-ps are only maintained to help Keycloak (which doesn't need MP) until it can move to Galleon.

This requires overrides of the Galleon domain config and the high level feature groups used in it in order to integrate the MP variant of domain-host-excludes.

    • -5
    • +37
    /ee-build/src/verifier/verifications.xml
    • -0
    • +37
    /ee-dist/src/verifier/verifications.xml
    • -2
    • +0
    /ee-galleon-pack/wildfly-feature-pack-build.xml
    • -102
    • +0
    /feature-pack/src/license/full-feature-pack-licenses.xml
    • -0
    • +102
    /galleon-pack/src/license/microprofile-feature-pack-licenses.xml
  1. … 30 more files in changeset.
[WFLY-12609] Add testsuite/layers executions for fault-tolerance and jwt

Also prune some unneeded feature-pack declarations from the openapi execution

WFLY-12958 add test to verify transaction attribute REQUIRED for async method.

Merge pull request #12836 from ehsavoie/WFLY-12758

[WFLY-12758]: Integrating OpenTracing

Merge pull request #12567 from emmartins/WFLY-11255

[WFLY-11255] Managed Executor Runtime Stats

WFLY-12959 Upgrade microprofile-fault-tolerance-api to 2.0.3

[WFLY-12894] Add clarification to the documentation regarding inline JWKS only supporting a single key and no support for Base64 encoded JWKS.

Merge pull request #12901 from bstansberry/clean_fp

[WFLY-12826] Clean out more unneeded f-p declarations

[WFLY-12826] Clean out more unneeded f-p declarations

    • -16
    • +0
    /testsuite/integration/basic/pom.xml
[WFLY-12985] Facilitate separate maven versions for ee dist vs complete dist

This may be useful for EAP.

  1. … 7 more files in changeset.
WFLY-12958 For Asynchronous EJB methods treat transaction attribute REQUIRED as REQUIRES_NEW since the caller's transaction context is not propagated.

WFLY-12958 Calling Asynchronous EJB will use the propagated caller transaction which is not according to the specification

Merge pull request #12895 from hpehl/WFLY-12943

WFLY-12943: Upgrade HAL to 3.2.5.Final

Merge pull request #12899 from bstansberry/gav-spacing

Add missing GAV separation comments

Add missing GAV separation comments

Merge pull request #12897 from jfdenise/WFLY-12955

Fix for WFLY-12955, Upgrade galleon to 4.2.3

Generalize ResourceCapabilityReference

[WFLY-12609] Add a microprofile-jwt layer and use it for the JWT TCK testing.

[WFLY-12609] Remove `microprofile-jwt-smallrye` subsystem and extension when testing EAP 7.3 and below.

Fix for WFLY-12955, Upgrade galleon to 4.2.3

[WFLY-12956] Add empty DomainAdjuster for EAP 7.3.0 specific adjustments.

[WFLY-12903] - EJBComponent.checkCallerSecurityIdentityRole check for null roles

WFLY-12943: Upgrade HAL to 3.2.5.Final

[WFLY-12609] Ensure the new MicroProfile JWT extension is excluded for use against older hosts.

[WFLY-12609] Add MicroProfile JWT subsystem to additional configurations.