Clone Tools
  • last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
[WFLY-12609] Add a new 'org.wildfly.security.elytron-jwt' module.

  1. … 4 more files in changeset.
[WFLY-12609] Add a new 'io.smallrye.jwt' module.

  1. … 5 more files in changeset.
[WFLY-12609] Add new 'org.eclipse.microprofile.jwt.auth.api' module.

  1. … 5 more files in changeset.
Next is 18.0.1.Final

  1. … 157 more files in changeset.
Next is 19.0.0.Beta1

  1. … 157 more files in changeset.
Prepare for 18.0.0.Final release

  1. … 157 more files in changeset.
[WFLY-12313] Add OpenAPI extension using SmallRye OpenAPI implementation

  1. … 39 more files in changeset.
Merge pull request #12549 from jimma/WFLY-12442

[WFLY-12442]:Upgrade jboss-saaj-api and saaj-impl from 1.3 to 1.4

  1. … 3 more files in changeset.
Merge pull request #12640 from jmesnil/WFLY-12554_upgrade_smallrye-health_2.0

[WFLY-12554][WFLY-12555] upgrade smallrye health 2.0 & MP Health 2.1

  1. … 2 more files in changeset.
Add jboss-transaction-api_1.3_spec dependency to feature-pack

[WFLY-12554] Upgrade smallrye-health 2.0

JIRA: https://issues.jboss.org/browse/WFLY-12554

  1. … 5 more files in changeset.
Merge pull request #12627 from tomjenkinson/WFLY-12300

Wfly 12300

  1. … 4 more files in changeset.
WFLY-12448 Updated the licences of the transaction API to match Jakarta and remove from the full-feature-pack and to remove the dependency from some unnecessary modules

  1. … 3 more files in changeset.
[WFLY-12524] Move com.sun.mail:javax.mail:1.6.2 to com.sun.mail:jakarta.mail-api:1.6.4

  1. … 8 more files in changeset.
[WFLY-12304]: Upgrade Apache Artemis from 2.8.1 to 2.10.1

* Updating artemis version

* Adding new dependency on jctools-core

* Adding a pure netty failover test

Jira: https://issues.jboss.org/browse/WFLY-12304

  1. … 16 more files in changeset.
Next is 18.0.0.Final

  1. … 156 more files in changeset.
Prepare for 18.0.0.Beta1 release

  1. … 156 more files in changeset.
Revert "WFLY-12460 Upgrade jboss-transaction-api_1.2_spec to jboss-transactio…"

  1. … 29 more files in changeset.
[WFLY-12442]:Upgrade jboss-saaj-api and saaj-impl from 1.3 to 1.4

  1. … 9 more files in changeset.
Merge pull request #12575 from jmesnil/WFLY-12474_upgrade_smallrye-metrics_2.1.4

[WFLY-12474] Upgrade smallrye-metrics 2.1.4

  1. … 3 more files in changeset.
WFLY-12480 Switch from javax.persistence:javax.persistence-api to jakarta.persistence:jakarta.persistence-api

  1. … 14 more files in changeset.
[WFLY-12474] Upgrade smallrye-metrics 2.1.4

* upgrade from smallrye-metrics-2.0:1.1.0 to smallrye-metrics:2.1.4.

There was a change in the version convention but this is a micro

update

* upgrade from microprofile-metrics:2.0.1 to 2.0.2 (micro upgrades)

* smallrye-metrics:2.1.4 incorporates fixes for WFLY-12403 and

WFLY-12413

JIRA: https://issues.jboss.org/browse/WFLY-12474

JIRA: https://issues.jboss.org/browse/WFLY-12475

JIRA: https://issues.jboss.org/browse/WFLY-12403

JIRA: https://issues.jboss.org/browse/WFLY-12413

  1. … 5 more files in changeset.
WFLY-12460 Upgrade jboss-transaction-api_1.2_spec to jboss-transaction-api_1.3_spec 2.0.0CR1

  1. … 29 more files in changeset.
WFLY-12434 Upgrade jboss-jakarta-connector-api_spec to 2.0.0.Final

  1. … 2 more files in changeset.
Merge pull request #12520 from Skyllarr/jakarta-migration-ee-security

[WFLY-12418] Move to jakarta.security.enterprise:jakarta.security.ent…

  1. … 4 more files in changeset.
[WFLY-12416] Remove org.jboss.spec.javax.rmi:jboss-rmi-api_1.0_spec from dependency management

  1. … 5 more files in changeset.
[WFLY-12418] Move to jakarta.security.enterprise:jakarta.security.enterprise-api and org.glassfish.soteria:jakarta.security.enterprise

  1. … 8 more files in changeset.
Merge branch 'master' into WFLY-12228_upgrade_microprofile-health_2.0.1

  1. … 6 more files in changeset.
[WFLY-12311] Use smallrye-metrics to expose subsystem metrics

* Replace use of prometheus simple client by smallrye-metrics to collect

and expose subsystem metrics

* use ExtendedMetadata for WildFly vendor metrics

* Remove io.prometheus:simpleclient and

io.prometheus:simpleclient_common dependencies

JIRA: https://issues.jboss.org/browse/WFLY-12311

  1. … 10 more files in changeset.
[WFLY-12294] Upgrade MicroProfile Metrics 2.0.1

* Update org.eclipse.microprofile-metrics to 2.0.1

* Update smallrye-metrics to io.smallrye-metrics-2.0:1.1.0

(both Maven A and V have changed)

* add dependency io.rest-assured:rest-assured:3.0.0 (in test scope) that

is required to run the Metrics REST TCK

* Fix integration tests due to specifitions changes in Prometheus

conversion (and HTTP status errors)

* update base metrics to comply with Metrics 2.0 specification

* add microprofile-metrics TCK (both API & REST) to the integration

testsuite

JIRA: https://issues.jboss.org/browse/WFLY-12294

  1. … 17 more files in changeset.