security

Clone Tools
  • last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Merge pull request #13591 from pferraro/WFLY-13885

WFLY-13885 SharedSessionTestCase should test non-distributed session manager

  1. … 28 more files in changeset.
Next is 21.0.0.Final

  1. … 178 more files in changeset.
Prepare for WildFly 21.0.0.Beta1 release

  1. … 178 more files in changeset.
[WFLY-13659] Ensure any subsystem dependencies on org.jboss.as.security use provided scope to prevent transitive use.

  1. … 6 more files in changeset.
[WFLY-13868] Refactor vault-tool so it no longer depends on the legacy security subsystem module.

    • -0
    • +110
    ./vault-tool/pom.xml
  1. … 8 more files in changeset.
[WFLY-13852] Eliminate dependency on the legacy security subsystem from the EJB3 subsystem.

  1. … 10 more files in changeset.
[WFLY-13848] Clean up import ordering for migrated classes.

[WFLY-13848] Move the "org.jboss.as.security.plugins" package into it's own module.

  1. … 23 more files in changeset.
Merge pull request #13045 from nekdozjam/WFLY-13146

[WFLY-13146] Support for multiple security realms - Failover

  1. … 11 more files in changeset.
Merge pull request #13448 from bstansberry/WFLY-13729

[WFLY-13729] Make optional the javax.sml.rpc.api module dependency ad…

  1. … 9 more files in changeset.
Merge pull request #13438 from soul2zimate/WFLY-13719

WFLY-13719 Add a system property to restore old behavior (Don't creat…

  1. … 3 more files in changeset.
Merge pull request #13008 from rmartinc/WFLY-13065

[WFLY-13065] Options for reverse-proxy max-request-time and connection-idle-timeout are specified as seconds

  1. … 22 more files in changeset.
[WFLY-13660] Register the 'org.wildfly.legacy-security.jacc' capability if JACC is being initialised.

Also ensure the PolicyConfigurationFactory is initialised.

Next is 20.0.2.Final

  1. … 169 more files in changeset.
Prepare for 20.0.1.Final release

  1. … 169 more files in changeset.
[WFLY-13648] Create a new 'security-integration' module which will contain a service descritptor for PolicyContextHandler.

This module should only be provisioned if legacy security is being provisioned due to the dependency on PicketBox.

    • -0
    • +45
    ./integration/pom.xml
  1. … 5 more files in changeset.
[WFLY-13601] Move the EarSecurityDeployer and related utility classes into the EE subsystem as it is no longer specific to the security subsystem.

  1. … 16 more files in changeset.
Next is 20.0.1.Final

  1. … 168 more files in changeset.
Next is 21.0.0.Beta1

  1. … 168 more files in changeset.
Prepare for 20.0.0.Final release

  1. … 168 more files in changeset.
Next is 20.0.0.Final

  1. … 168 more files in changeset.
Prepare for 20.0.0.Beta1 release

  1. … 168 more files in changeset.
[WFLY-12516] - set identities and roles only in case of new subjectinfo

Next is 19.1.1.Final

  1. … 168 more files in changeset.
Prepare for 19.1.0.Final release

  1. … 168 more files in changeset.
Next is 19.1.0.Final

  1. … 168 more files in changeset.
Next is 19.0.1.Final

  1. … 168 more files in changeset.
Prepare for 19.0.0.Final release

  1. … 168 more files in changeset.
Next is 19.0.0.Beta4

  1. … 168 more files in changeset.
Prepare for 19.0.0.Beta3 release

  1. … 168 more files in changeset.