Clone
Brian Stansberry
committed
on 11 Jan
[WFLY-11587] Fix Weld integration with legacy security
1) Correct SecuritySubsystemRootResourceDefinition so it actually registers the org.w… Show more
[WFLY-11587] Fix Weld integration with legacy security

1) Correct SecuritySubsystemRootResourceDefinition so it actually registers the org.wildfly.legacy-security.server-security-manager capability

2) Correct the module import as ServerSecurityManager is not from the security subsystem module, it's from WildFly Core's org.jboss.as.core.security.

3) Add a test of the use of @Inject Principal

Show less