JBossToolsBuild

Clone Tools
  • last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
bump parent pom to BUILD_ALIAS = AM3

Signed-off-by: nickboldt <nboldt@redhat.com>

typo fix

Signed-off-by: nickboldt <nboldt@redhat.com>

JBIDE-25736 remove freemarker and arquillian from JBT

Signed-off-by: nickboldt <nboldt@redhat.com>

JBIDE-25598 - bump up to use TP = 4.73.AM2-SNAPSHOT

Signed-off-by: nickboldt <nboldt@redhat.com>

[JBIDE-25744] - JDK9 profile should be auto detected and allow next version of Java (10,...)

Signed-off-by: Jeff MAURY <jmaury@redhat.com>

bump parent pom to BUILD_ALIAS = AM2

Signed-off-by: nickboldt <nboldt@redhat.com>

Fix typo

Signed-off-by: Aurélien Pupier <apupier@redhat.com>

use tychoVersion = 1.1.0 in jdk9 profile

Signed-off-by: nickboldt <nboldt@redhat.com>

use latest jbosstoolsRelengPublishVersion = 4.5.3.AM1-SNAPSHOT

Signed-off-by: nickboldt <nboldt@redhat.com>

Tycho 1.1 is released, so switch to that instead of snapshot

Signed-off-by: nickboldt <nboldt@redhat.com>

Revert "JBIDE-25675 temporarily disable org.jboss.tools.tycho-plugins:repository-utils:1.0 to see if anything else is broken when building with Tycho 1.1"

This reverts commit aa4d24feead1dfa3df9573c20fa01bde468bdd23.

use Tycho 1.1.0-SNAPSHOT in parent pom

Signed-off-by: nickboldt <nboldt@redhat.com>

JBIDE-18654 bump up to jacoco.version = 0.8.0

Signed-off-by: nickboldt <nboldt@redhat.com>

JBIDE-25675 temporarily disable org.jboss.tools.tycho-plugins:repository-utils:1.0 to see if anything else is broken when building with Tycho 1.1

Signed-off-by: nickboldt <nboldt@redhat.com>

bump parent pom to BUILD_ALIAS = AM1

Signed-off-by: nickboldt <nboldt@redhat.com>

Revert "bump root pom to 4.5.3.AM1-SNAPSHOT"

This reverts commit d57d4e58e82a163036c6e77acd56a1ad08f0a757.

Revert "bump root pom to 4.5.3.AM1-SNAPSHOT"

This reverts commit ec3c892dc5c894565e8724b6275563aeb6a616b8.

bump root pom to 4.5.3.AM1-SNAPSHOT

Signed-off-by: nickboldt <nboldt@redhat.com>

bump root pom to 4.5.3.AM1-SNAPSHOT

Signed-off-by: nickboldt <nboldt@redhat.com>

use TP MIN = 4.71.1.Final and MAX = 4.72.0.Final

Signed-off-by: nickboldt <nboldt@redhat.com>

use latest TPs: MIN = 4.71.1.Final-SNAPSHOT, MAX = 4.72.0.Final-SNAPSHOT, central = 4.72.0.Final-SNAPSHOT

Signed-off-by: nickboldt <nboldt@redhat.com>

bump parent pom to 4.5.2.Final-SNAPSHOT with BUILD_ALIAS = Final

Signed-off-by: nickboldt <nboldt@redhat.com>

Update Tycho Surefire and Jacoco to allow Java9 based testing

- Update Jacoco for jdk9 profile only

Signed-off-by: Jeff MAURY <jmaury@redhat.com>

Revert "Revert "Update Tycho Surefire and Jacoco to allow Java9 based testing" Builds are now failing due to:"

This reverts commit 9f0d7269b136c5ea258fed025aec9f45ac4afedf.

Revert "Update Tycho Surefire and Jacoco to allow Java9 based testing"

This reverts commit 34bd530871bf884c847b777dd4b3d0dbf0976032.

Revert "Update Tycho Surefire and Jacoco to allow Java9 based testing" Builds are now failing due to:

/mnt/hudson_workspace/workspace/jbosstools-base_master/jacoco/jacoco-reports.xml:13: Unable to read execution data file /mnt/hudson_workspace/workspace/jbosstools-base_master/sources/common/target/jacoco.exec

Caused by: java.io.IOException: Incompatible version 1007.

This reverts commit 34bd530871bf884c847b777dd4b3d0dbf0976032.

Update Tycho Surefire and Jacoco to allow Java9 based testing

Signed-off-by: Jeff MAURY <jmaury@redhat.com>

oops, central TP still at version 4.72.0.AM2-SNAPSHOT

Signed-off-by: nickboldt <nboldt@redhat.com>

JBIDE-25514 upgrade to maven-dependency-plugin 3.0.2 (#266)

Signed-off-by: nickboldt <nboldt@redhat.com>

add jdk9 profile for use with tycho 1.1.0-SNAPSHOT. Use with -U -Pjdk9 -Pjdeps check main and test classes

Signed-off-by: nickboldt <nboldt@redhat.com>