JBossToolsGwt

Clone Tools
  • last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
JBIDE-8838: Added .gitkeep in empty folders for git-svn

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@39632 a97e2381-89e5-4abb-bab3-167db6db766c

JBIDE-10596: Move to eclipse-repository instead of eclipse-update-site

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@39511 a97e2381-89e5-4abb-bab3-167db6db766c

JBIDE-11157 Add JBoss repositories reference in components

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@39501 a97e2381-89e5-4abb-bab3-167db6db766c

JBIDE-11157 Follow maven naming convention for parent

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@39473 a97e2381-89e5-4abb-bab3-167db6db766c

JBIDE-10825 * move to Tycho 0.14.0 * uncreased parent pom version * clean build.properties * Specific config to ignore optional dependencies at build time

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@39050 a97e2381-89e5-4abb-bab3-167db6db766c

[JBIDE-9686] added dependency to "com.google.gdt.eclipse.suite" to avoid errors in eclipse log.

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@38929 a97e2381-89e5-4abb-bab3-167db6db766c

set version range [2.3.0,3.0.0) instead of just 2.3.0 (JBIDE-10742)

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@38255 a97e2381-89e5-4abb-bab3-167db6db766c

https://issues.jboss.org/browse/JBIDE-8997 (CLONE - 2010 in the copyright headers should be replaced by 2012) copyright text updated with current year

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@38053 a97e2381-89e5-4abb-bab3-167db6db766c

JBIDE-10230 more specific feature descriptions

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@36968 a97e2381-89e5-4abb-bab3-167db6db766c

JBIDE-9140 upversion parent pom references to 0.0.3

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@35576 a97e2381-89e5-4abb-bab3-167db6db766c

Marked usage as required (none optional). Dependency cannot be optional, if classes from dependency are directly referenced in plugin. Usage reporting plug-in cannot be optional dependency or build will fail.

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@35021 a97e2381-89e5-4abb-bab3-167db6db766c

corrected build.properties, extracted keys from features.xml

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@34368 a97e2381-89e5-4abb-bab3-167db6db766c

JBIDE-9585 do not need eGit 1.1; also, fix comments in pom-core.xml to explain why GWT not in TP

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@34312 a97e2381-89e5-4abb-bab3-167db6db766c

JBIDE-9268 aligned examples, xulrunner(partial), gwt, cdi, site, maven, portlet and runtime

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@33300 a97e2381-89e5-4abb-bab3-167db6db766c

    • -2
    • +2
    /plugins/org.jboss.tools.gwt.core/pom.xml
    • -2
    • +2
    /plugins/org.jboss.tools.gwt.ui/pom.xml
[JBIDE-8653] rebuilt the archives with the sample using GWT 2.3

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@33130 a97e2381-89e5-4abb-bab3-167db6db766c

[JBIDE-9338] updated dependencies to GWT 2.3 for Eclipse Indigo

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@33128 a97e2381-89e5-4abb-bab3-167db6db766c

[JBIDE-9338] updated dependencies to GWT 2.3 for Eclipse Indigo

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@33107 a97e2381-89e5-4abb-bab3-167db6db766c

    • -1
    • +1
    /plugins/org.jboss.tools.gwt.core/pom.xml
add GWT for Eclipse 3.7 site to repositories from which to resolve when building (https://issues.jboss.org/browse/JBDS-1729)

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@33106 a97e2381-89e5-4abb-bab3-167db6db766c

[JBIDE-9338] updated dependencies to GWT 2.3 for Eclipse Indigo

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@33103 a97e2381-89e5-4abb-bab3-167db6db766c

https://issues.jboss.org/browse/JBDS-1636 fix copyright statements to include 2011 upper bound and use Red Hat, Inc. instead of JBoss by Red Hat

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@31839 a97e2381-89e5-4abb-bab3-167db6db766c

https://issues.jboss.org/browse/JBIDE-8518 fix pom.xml files in JBT and JBDS repo such that only component root poms reference parent pom (all others just look up to .. for parent) cdi counfig.ui.test plugin fix final fix for: profiler workingset bpmn forge usage site maven bot.test gwt

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@31759 a97e2381-89e5-4abb-bab3-167db6db766c

    • -7
    • +7
    /plugins/org.jboss.tools.gwt.core/pom.xml
    • -7
    • +7
    /plugins/org.jboss.tools.gwt.ui/pom.xml
JBIDE-8191 2010 in the copyright headers should be replaced by 2011

git-svn-id: http://svn.jboss.org/repos/jbosstools/branches/jbosstools-3.2.x@31469 a97e2381-89e5-4abb-bab3-167db6db766c

[JBIDE-8145] removed dependency to gwt sdk

git-svn-id: http://svn.jboss.org/repos/jbosstools/branches/jbosstools-3.2.x@30681 a97e2381-89e5-4abb-bab3-167db6db766c

[JBIDE-8145] added dependency to com.google.gdt.eclipse.suite so that it gets pulled from update site when installing

git-svn-id: http://svn.jboss.org/repos/jbosstools/branches/jbosstools-3.2.x@30676 a97e2381-89e5-4abb-bab3-167db6db766c

increase gwt component version

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@29970 a97e2381-89e5-4abb-bab3-167db6db766c

increase gwt component version

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@29914 a97e2381-89e5-4abb-bab3-167db6db766c

    • -2
    • +2
    /plugins/org.jboss.tools.gwt.core/pom.xml
    • -2
    • +2
    /plugins/org.jboss.tools.gwt.ui/pom.xml
[JBIDE-7956] sticking to com.google.gwt.eclipse.sdkbundle to 2.1.1 for maintenance

git-svn-id: http://svn.jboss.org/repos/jbosstools/branches/jbosstools-3.2.x@29574 a97e2381-89e5-4abb-bab3-167db6db766c

[JBIDE-7956] removed version range for required com.google.gwt.eclipse.core and updated com.google.gwt.eclipse.sdkbundle to 2.2.0

git-svn-id: http://svn.jboss.org/repos/jbosstools/branches/jbosstools-3.2.x@29564 a97e2381-89e5-4abb-bab3-167db6db766c

[JBIDE-7956] removed version range for required com.google.gwt.eclipse.core and updated com.google.gwt.eclipse.sdkbundle to 2.2.0

git-svn-id: http://svn.jboss.org/repos/jbosstools/trunk@29563 a97e2381-89e5-4abb-bab3-167db6db766c