JBossToolsHibernate

Clone Tools
  • last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
JBIDE-26513: Remove the dependency on 'org.hibernate.eclipse' from 'org.jboss.tools.hibernate.runtime.v_x_y' - Remove dependency from org.jboss.tools.hibernate.runtime.v_3_6

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26513: Remove the dependency on 'org.hibernate.eclipse' from 'org.jboss.tools.hibernate.runtime.v_x_y' - Remove dependency from org.jboss.tools.hibernate.runtime.v_3_5

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26512: Use version 1.1.1.Final of jboss-transaction-api_1.2_spec instead of geronimo-jta_1.1

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26511: Update byte buddy version to 1.9.5 in org.jboss.tools.hibernate.runtime.v_5_4

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26508: Update classmate version to 1.3.4 in org.jboss.tools.hibernate.runtime.v_5_4

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26509: Update dependency on hibernate commons annotations to version 5.1.0.Final where appropriate - update dependency in org.jboss.tools.hibernate.runtime.v_5_4

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26508: Update hibernate tools dependency of org.jboss.tools.hibernate.runtime.v_5_4 to version 5.4.0.Final

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26498 - coretests failing because of an hibernate dependency missing (#636)

Signed-off-by: Jeff MAURY <jmaury@redhat.com>

JBIDE-26499: Update hibernate tools dependency of org.jboss.tools.hibernate.runtime.v_5_4 to version 5.4.0.CR2

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26498 - coretests failing because of an hibernate dependency missing (#634)

Signed-off-by: Jeff MAURY <jmaury@redhat.com>

JBIDE-26486 #comment bump up to parent pom version = 4.11.0.AM1-SNAPSHOT #close

Add support for Hibernate 5.4 - Make the tests in 'org.jboss.tools.hibernate.orm.test' run with 5.4

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26474: Add support for Hibernate 5.4

Signed-off-by: Koen Aers <koen.aers@gmail.com>

  1. … 48 more files in changeset.
JBIDE-26473: Update hibernate tools dependency of org.jboss.tools.hibernate.runtime.v_5_2 to version 5.2.12.Final

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26437: Make the Hibernate Tools work with Java 10 - Add jaxb-impl to the org.jboss.tools.hibernate.runtime.v_5_0 classpath

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26437: Make the Hibernate Tools work with Java 10 - Add jaxb-impl to the org.jboss.tools.hibernate.runtime.v_5_1 classpath

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-25553: Cannot create Hibernate Console Configuration for projects with java 9 - Enable test for packages 'core.jpa.fetch', 'core.lazycache' and 'core.lazyonetoone'

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26437: Make the Hibernate Tools work with Java 10 - Add jaxb-impl to the org.jboss.tools.hibernate.runtime.v_5_2 classpath

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-25553: Cannot create Hibernate Console Configuration for projects with java 9 - Enable test for packages 'core.jpa.cascade' and 'core.lob'

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-25553: Cannot create Hibernate Console Configuration for projects with java 9 - Enable test for packages 'core.jpa' and 'core.manytomany'

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26437: Make the Hibernate Tools work with Java 10 - Add jaxb-impl to the org.jboss.tools.hibernate.runtime.v_5_3 classpath

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26448: Update hibernate tools dependency of org.jboss.tools.hibernate.runtime.v_5_3 to version 5.3.7.Final

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-25553: Cannot create Hibernate Console Configuration for projects with java 9 - Enable test for packages 'core.joinfetch' and 'core.manytomany.ordered'

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26437: Make the Hibernate Tools work with Java 10 - Add plugin org.jboss.tools.hibernate.libs.jaxb-core.v_2_3_0

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-25553: Cannot create Hibernate Console Configuration for projects with java 9 - Enable test for packages 'core.joinedsubclass' and 'core.map'

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26437: Make the Hibernate Tools work with Java 10 - Add plugin org.jboss.tools.hibernate.libs.jaxb-api.v_2_3_0

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-25553: Cannot create Hibernate Console Configuration for projects with java 9 - Enable test for packages 'core.join and 'core.mapcompelem'

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26437: Make the Hibernate Tools work with Java 10 - Add plugin org.jboss.tools.hibernate.libs.activation.v_1_2_0

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-25553: Cannot create Hibernate Console Configuration for projects with java 9 - Enable test for packages 'core.iterate' and 'core.mapelemformula'

Signed-off-by: Koen Aers <koen.aers@gmail.com>

JBIDE-26437: Make the Hibernate Tools work with Java 10 - Initial changes to make the tests run on Java 10 and Java 11

Signed-off-by: Koen Aers <koen.aers@gmail.com>