Clone Tools
  • last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
[WFCORE-4770] Fix logging in CLI

  1. … 3 more files in changeset.
[WFCORE-4798] Add necessary module dependencies to elytron-private module

[WFCORE-4700] Add wildfly-elytron-jwt module.

  1. … 1 more file in changeset.
[WFCORE-4648] Migrate javax.json to jakarta.json

    • -0
    • +41
    ./org/glassfish/jakarta/json/main/module.xml
    • -14
    • +1
    ./org/glassfish/javax/json/main/module.xml
  1. … 11 more files in changeset.
WFCORE-4599 Handle wildfly-config.xml better for authentication

This was previously cached in a static, which does not work for

multiple deployments. This uses an empty authentication context

for the default (if it was not explicitly set), then explicitly

sets per-deployment ClassLoader default to make sure the correct

class loader is in use when the config is loaded.

  1. … 2 more files in changeset.
Fix for WFCORE-4428, upgrade to aesh 2.4 and readline 2.0

  1. … 12 more files in changeset.
Fix for WFCORE-4428, upgrade to aesh 2.4 and readline 2.0

  1. … 12 more files in changeset.
WFCORE-4535 WildFly discovery subsystem registers capabilities using an ambiguous contract` WFCORE-4541 /subsystem=discovery/static-provider=foo:write-attribute operation fails with StackOverflowError

  1. … 12 more files in changeset.
[WFCORE-4531] Eliminating WildFly naming workaround introduced in WFLY-10394.

    • -2
    • +0
    ./org/wildfly/extension/io/main/module.xml
[WFCORE-4467] Upgrade WildFly Elytron to 1.9.0.Final

  1. … 3 more files in changeset.
[WFCORE-4394] Enhanced Audit Logging for Elytron - RFC Support and Reliability/Speed Customization

  1. … 13 more files in changeset.
[WFCORE-4417] Upgrade WildFly Elytron to 1.9.0.CR3

  1. … 5 more files in changeset.
[WFCORE-4417] Upgrade WildFly Elytron to 1.9.0.CR3

  1. … 5 more files in changeset.
[WFCORE-4413] Fixing javax.api and javax.sql.api modules backward compatibility issues

[WFCORE-4413] Fixing javax.api and javax.sql.api modules backward compatibility issues

[WFCORE-4401] Make the 'org.wildfly.security.password.util' package public.

[WFCORE-4373] org.jboss.log4j.logmanager module requires java.sql module

[WFCORE-4373] org.jboss.log4j.logmanager module requires java.sql module

[WFCORE-4374] security-manager permissions are loaded using java.se module

[WFCORE-4374] security-manager permissions are loaded using java.se module

[WFCORE-4369] Fixing JDK 13 test issue - com.sun.net.ssl.internal.ssl.Provider was replaced with sun.security.ssl.SunJSSE.

  1. … 5 more files in changeset.
[WFCORE-4355] Introduce a simple event logging API.

    • -0
    • +34
    ./org/wildfly/event/logger/main/module.xml
  1. … 23 more files in changeset.
[WFCORE-4355] Introduce a simple event logging API.

    • -0
    • +34
    ./org/wildfly/event/logger/main/module.xml
  1. … 23 more files in changeset.
[WFCORE-4340] Upgrading JBoss Invocation plus providing utility ModuleClassFactory to be used by other WildFly components.

  1. … 3 more files in changeset.
[WFCORE-4340] Upgrading JBoss Invocation plus providing utility ModuleClassFactory to be used by other WildFly components.

  1. … 3 more files in changeset.
[WFCORE-4265] Latest DB2 11.1 JDBC driver requires additional IBM JDK system dependency

[WFCORE-4265] Latest DB2 11.1 JDBC driver requires additional IBM JDK system dependency

[WFCORE-4259] Prepare for the modularised WildFly Elytron.

  1. … 8 more files in changeset.
[WFCORE-4259] Prepare for the modularised WildFly Elytron.

  1. … 8 more files in changeset.
[WFCORE-4206] Remove javax.annotation.api un-used optional dependency from Elytron extension