WildFlyElytron

Clone Tools
  • last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Merge branch '1.6.x' into 1.7.x

[ELY-1827] Update JAPICMP version to compare against 1.6.3.Final

Merge branch '1.6.x' into 1.7.x

Next is 1.6.4

[ELY-1827] Release WildFly Elytron 1.6.3.Final

Merge branch '1.6.x' into 1.7.x

Merge pull request #1293 from ivassile/JBEAP-17004

[ELY-1826] Cannot connect to management interface with Java Security Manager enabled

Merge pull request #1284 from darranl/ELY-1810/1.6.x

[ELY-1810] Only check the permission against the current SecurityIdentity if it is a JACC permission.

[ELY-1826] Cannot connect to management interface with Java Security Manager enabled

Merge pull request #1279 from ivassile/JBEAP-16836

[ELY-1634] LDAPS referrals broken

[ELY-1810] Only check the permission against the current SecurityIdentity if it is a JACC permission.

Merge branch '1.6.x' into 1.7.x

Next is 1.6.3

[ELY-1755] Release WildFly Elytron 1.6.2.Final

Merge pull request #1233 from darranl/ELY-1464/1.6.x

[ELY-1464] Programatic authentication should be caching the SecurityIdentity not the name of the identity

Merge pull request #1224 from darranl/ELY-1747/1.6.x

[ELY-1747] If programmatic authentication is successful associate the credential with the identity.

Merge pull request #1221 from ivassile/JBEAP-16151

[ELY-1702] Update mockserver-netty to 5.4.1

Merge pull request #1220 from ivassile/JBEAP-16150

[ELY-1678] Avoid NPE in AcmeClientSpi#checkContentType() and [ELY-1699] Intermittently failing AcmeClientSpiTest

Merge pull request #1219 from ivassile/JBEAP-15636

[ELY-1693] Update AcmeClientSpi to make use of POST-as-GET requests instead of GET requests and update tests accordingly

[ELY-1464] Use a CachedIdentity to store the SecurityIdentity in the session.

[ELY-1464] There is no advantage to using a Supplier as get() is always called within the constructors so better to pass in the Principal.

[ELY-1747] If programmatic authentication is successful associate the credential with the identity.

[ELY-1693] Update AcmeClientSpi to make use of POST-as-GET requests instead of GET requests and update tests accordingly

Next is 1.7.1

[ELY-1709] Release WildFly Elytron 1.7.0.Final

Merge branch '1.6.x'

Merge branch '1.3.x' into 1.6.x

Merge branch '1.2.x' into 1.3.x

Merge branch '1.1.x' into 1.2.x

Next is 1.1.13