WeldCore

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
WELD-2570 Fix WebAppBeanArchiveScanner not excluding duplicate bean.xml correctly

WELD-2628 Fix integer overflow when sorting alternatives (#1999)

WELD-2629 Correct ConversationContextDestroyedOnSessionTimeoutTest to properly trigger session timeout.

Attempt to fix intemittent failures in RequestScopeEventMessageDeliveryTest by making certain fields final to prevent possible concurrent write.

WELD-2625 Correct the exclude formula for jacoco to avoid including TCK sources.

WELD-2624 For TCK 1.2 tests, exclude javax version of SOAP API and include jakarta one instead.

WELD-2624 Setup TCK 1.2 execution with proper artifacts.

honour resetHttpSessionAttributeOnBeanAccess in AbstractConversationContext

[maven-release-plugin] prepare for next development iteration

    • -1
    • +1
    /environments/servlet/tests/base/pom.xml
    • -1
    • +1
    /environments/servlet/tests/jetty/pom.xml
  1. … 26 more files in changeset.
[maven-release-plugin] prepare release 3.1.4.Final

    • -1
    • +1
    /environments/servlet/tests/base/pom.xml
    • -1
    • +1
    /environments/servlet/tests/jetty/pom.xml
  1. … 26 more files in changeset.
WELD-2613 Remove Unsafe usage from class defining logic.

WELD-2609 Fix OM configurator when reading from an AnnotatedMethod.

Do not require specific OSGi versions of Jakarta APIs

WELD-2615: Fix AttributeBeanStore.remove()

- HttpSessionContext#destroy(Contextual<?>) should always destroy the

underlying contextual instance

Update CDI TCK to 2.0.6.SP1.

Bump tomcat.version from 9.0.30 to 9.0.31 in /probe/tests

Bumps `tomcat.version` from 9.0.30 to 9.0.31.

Updates `tomcat-embed-core` from 9.0.30 to 9.0.31

Updates `tomcat-embed-jasper` from 9.0.30 to 9.0.31

Signed-off-by: dependabot[bot] <support@github.com>

Bump tomcat.version from 9.0.30 to 9.0.31 in /environments/servlet

Bumps `tomcat.version` from 9.0.30 to 9.0.31.

Updates `tomcat-embed-core` from 9.0.30 to 9.0.31

Updates `tomcat-embed-jasper` from 9.0.30 to 9.0.31

Updates `tomcat-catalina` from 9.0.30 to 9.0.31

Signed-off-by: dependabot[bot] <support@github.com>

WELD-2612 Conversation cleanup doesn't need to acquire two lock at the same time.

Cover case where cid is empty

Update Weld parent, satisfy checkstyle.

Try upgrading Shrinkwrap versions.

WELD-2611 Fire @Initialized event for conversation context after failed attempt to recover non-existing conversation.

WELD-2610: Fix destruction events for conversation context

Bump tomcat.version from 9.0.29 to 9.0.30 in /probe/tests

Bumps `tomcat.version` from 9.0.29 to 9.0.30.

Updates `tomcat-embed-core` from 9.0.29 to 9.0.30

Updates `tomcat-embed-jasper` from 9.0.29 to 9.0.30

Signed-off-by: dependabot[bot] <support@github.com>

Bump tomcat.version from 9.0.29 to 9.0.30 in /environments/servlet

Bumps `tomcat.version` from 9.0.29 to 9.0.30.

Updates `tomcat-embed-core` from 9.0.29 to 9.0.30

Updates `tomcat-embed-jasper` from 9.0.29 to 9.0.30

Updates `tomcat-catalina` from 9.0.29 to 9.0.30

Signed-off-by: dependabot[bot] <support@github.com>

Close weld.properties stream in finally block

Fix failing Probe test on CI.

Add JDK 11 to Travis testing matrix, update distro that is used.

Update WFLY version to 18 in patch creating Maven settings.

[maven-release-plugin] prepare for next development iteration

    • -1
    • +1
    /environments/servlet/tests/base/pom.xml
    • -1
    • +1
    /environments/servlet/tests/jetty/pom.xml
  1. … 26 more files in changeset.