SwitchYardTools

Clone Tools
  • last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Update pom.xml

FUSETOOLS-2387 - Upgrade TP to 4.4.3.CR2

JBTIS-1092 - updating JBTIS 4.4.3.CR1 for Neon (#665)

SWITCHYARD-3007 - cherry picking fixes for SWITCHYARD-2995 and SWITCHYARD-2999 back to 2.3.x (#664)

* SWITCHYARD-2995 - fixing cast error for port in rest binding (#654)

-- also fixing for rest proxy

-- also fixing for http binding & proxy

-- also fixing for soap proxy & binding

-- also doing a little cleanup of easy warnings to eliminate

-- will do some additional code cleanup in a separate JIRA

-- responded to additional feedback from Aurelien

-- addressed a bunch of SonarLint recommendations

* SWITCHYARD-2999 - fixes for domain properties page (#656)

-- addresssed feedback from Lars

FUSETOOLS-2365 - Use Fuse Tooling 9.2.0

FUSETOOLS-2364 - Upgrade 2.3.x to 2.3.1-SNAPSHOT

  1. … 31 more files in changeset.
FUSETOOLS-2315 - Remove camel xsd cache

the camel xsd cache is already provided by Fuse Tooling

FUSETOOLS-2269 - Upgrade Target Platform to 4.4.1.Final

SWITCHYARD-2988 - updating TP (#651)

-- also adjusting org.eclipse.core.runtime version to be more up to date

- hasn't changed in forever

-- also updated the path to the latest BPMN2 modeler for neon

SWITCHYARD-2963 - fixing issue for copynamespaces in older versions (#650)

-- check to see if we're on the 2.1+ version before doing anything with

the copyNamespaces option on soap service bindings to avoid adding it

where it should not be added

SWITCHYARD-2984 - fixed issue with unwrapped checkbox on soap bindings (#649)

-- unwrapped checkbox now is always enabled across all versions

-- copynamespaces checkbox is handled a bit more intelligently to avoid

introducing validation errors in 2.0.x or below.

-- updated code to avoid situation where you could not select both

checkboxes and make the change stick

FUSETOOLS-2237 - Follow API update for custom palette entries

- SwitchYard component is available only for Karaf

FUSETOOLS-2232 - Update year from 2016 to 2017

update only for copyrights in features

FUSETOOLS-2213 - Upgrade Target Platform to 4.4.1.CR1

SWITCHYARD-2976 - update to org.slf4j reference (#645)

Merge pull request #642 from bfitzpat/SWITCHYARD-2972-validation

SWITCHYARD-2972 - removing validation error for rest bindings

FUSETOOLS-2205 - Add fragment dependency in test TP (#643)

org.eclipse.osgi.compatibility.state is required but is no more by

default in the test Target Platform, so add it explicitly as M2E

utilities tests requires it

SWITCHYARD-2972 - removing validation error for rest bindings

FUSETOOLS-2205 - Add fragment dependency in test TP

org.eclipse.osgi.compatibility.state is required but is no more by

default in the test Target Platform, so add it explicitly as M2E

utilities tests requires it

SWITCHYARD-2971 - updating to final neon TP (#638)

SWITCHYARD-2959 - ensuring that previous version is in SY version (#634)

drop-down list. In this case, 2.0.0.Final

- also refactored some code for a bit easier testing

- added new test

- updated to remove if (!contains) statements (unneeded since we're

adding to a set, which guarantees uniqueness)

SWITCHYARD-2968 - adding workaround for mac issue (#637)

SWITCHYARD-2963 - adding a check to ensure that the runtime is 2.1 or (#632)

higher for the new unwrapped and copyNamespaces options to be saved in

the configuration file.

- also add a utility in the base class so we can reuse this

functionality if we need to do this kind of check again

- set the default to true - assume we're at the highest level

SWITCHYARD-2967 - fixing jboss-tycho-version property value (#635)

SWITCHYARD-2966 - checking to make sure editor isn't null (#633)

SWITCHYARD-2964 - updating version of master to 2.3.0 (#631)

* SWITCHYARD-2964 - updating version of master to 2.3.0

- also updated the fuse-tooling-url to point to 9.1.0.CI

* SWITCHYARD-2964 - updating version of master to 2.3.0

- also updated the fuse-tooling-url to point to 9.1.0.CI

  1. … 35 more files in changeset.
FUSETOOLS-2171 - using 0.26.0-SNAPSHOT

FUSETOOLS-2171 - upgrade to Neon TP 4.4.0.CR1

SWITCHYARD-2951: Project wizard doesn't detect IntPkg version if the version was typed (#629)

SWITCHYARD-2386 - neon - fixing the other half of the promote problem (#596)

Thanks folks!