Clone
 

petr široký <siroky.petr@gmail.com> in Errai

[ERRAI-1084] upgrade mockito, gwtmockito and powermock to versions compatible with JDK9

  1. … 4 more files in changeset.
Upgrade GWT to 2.8.2

GWT 2.8.2 is the first release that should support bulding with Java 9

(it does not support Java 9 features; just the legacy classpath mode)

    • -1
    • +1
    /errai-demos/errai-bus-demo-stock/pom.xml
    • -1
    • +1
    /errai-demos/errai-jpa-demo-basic/pom.xml
    • -1
    • +1
    /errai-demos/errai-security-demo/pom.xml
    • -1
    • +1
    /errai-demos/errai-ui-demo-i18n/pom.xml
  1. … 3 more files in changeset.
Replace sun.misc.BASE64Encoder with java.util.Base64

sun.misc.BASE64Encoder is no longer accessible in Java 9.

Replace org.codehaus.jackson with com.fasterxml.jackson

    • -2
    • +2
    /errai-jaxrs/errai-jaxrs-client/pom.xml
IP BOM 7.0.0.CR5 (#212)

* [ERRAI-971] upgrade IP BOM to 7.0.0.CR5

* CR5 brings JPA 2.1 + Hibernate 5.x

(upgraded from JPA 2.0 + Hibernate 4.x)

* Fix errai-jpa-client tests and jpa demo GWT compilation errors.

* Add missing attribute to JoinColumn annotation.

* Add ForeignKey and ConstraintMode types.

* Fix HibernateJpaTest/ErraiJpaTest to work with different hibernate behaviour.

    • -1
    • +1
    /errai-demos/errai-security-demo/pom.xml
    • -1
    • +1
    /errai-demos/errai-ui-demo-i18n/pom.xml
  1. … 5 more files in changeset.
32x ip bom and javassist (#183)

* Upgrade IP BOM to 6.0.6.Final

* security-server: replace old javassist:javassist with org.javassist:javassist

* old javassist:javassist does not support Java 8 and since it uses

different groupId, Maven brings both into classpath and that

results in "random" failures on Java 8

[ERRAI-960] upgrade IP BOM to 7.0.0.CR4 + general POM clean-up (#180)

* removing depMgmt for artifacts which are already

coming from IP BOM

* better alignment with IP BOM

* using plugin version from IP BOM/JBoss Parent

* fixes related to JEE Spec upgrades

* Use version 2.8.0-beta1 of gwt-maven-plugin

    • -4
    • +4
    /errai-demos/errai-jpa-demo-basic/pom.xml
  1. … 37 more files in changeset.
WildFly 10 upgrade (#176)

* Upgrade wildfly dependencies to support dev mode with Wildfly 10.

* Upgrade wildfly-dist to 10.0.0.Final in demos.

    • -1
    • +1
    /errai-demos/errai-security-demo/pom.xml
Upgrade ip-bom to 7.0.0.CR1 (#166)

* ip-bom import moved into errai-bom so that

all 3rd party dependencyManagement can happen

there